Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error in hrev 50028
#11
(01-30-2016, 03:48 AM)bbjimmy Wrote: yab 1.7.5.2 is available from the FatElk repo. This will require haiku hrev50032, the version it was build on, or higher.

The issue isn't as bad as I first feared. After installing this version, any yab program built or bound with a version of yab that uses libyab.so on a PM version of haiku will run again. Those made with earlier versions of yab or Haiku will have to be re-built.

But users with an older version does not have the chance to use your apps if you update them on your repository server.
Reply
#12
Are you upset that I fixed yab to work on recent nightlies? No matter what the outcome of the ticket, this will be required.

The GetLatest-yab script http://yab.orgfree.com/GetLatest-yab.zip has been updated to work with this change, only commenting out the line in the ColorTools.h file for the latest nightlies. Any yab program built / bound on a PM nightly will work with this change as the change only modifies libyab.so, but is compatible with previous versions.

All I can do is insure backward compatibility and with this change to haiku that is limited to PM versions of Haiku and yab 1.7.5 or higher. There may be a way to do a binary patch for older versions, but that is beyond my pay grade.

In order to convince the Haiku devs that this is indeed an issue, a comment on https://dev.haiku-os.org/ticket/12592 listing apps that don't work on recent nightlies might be a help.
Reply
#13
They are looking at closing the ticket. If you believe this needs to be fixed in Haiku, not just changing yab, you should comment on it. https://dev.haiku-os.org/ticket/12592#comment:15
Reply
#14
This ticket has been closed by the Haiku devs as I am the only person to have argued for it to be fixed in Haiku. We will all need to re-build our programs and test them in recent nightlies.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Free Web Hosting