Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
That's funny
05-10-2017, 05:48 AM
Post: #1
That's funny
Haven't seen this before: I'm filling a listbox with content

Code:
sub FillListbox()
    local listing$, listing, w$(1)
    listing$ = system$("ls -1 ~")
    listing = token(listing$, w$(), "\n")
    for f = 1 to listing
        listbox add "TheList", f, w$(f)
    next f
end sub

and when run, the program writes this to standard output, whether DEBUG=1 or not

Code:
Range: 241.000000 - 243.000000
Range: 56.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000

It's not important, but I prefer my programs to output text only when I tell it to. This happens on Haiku href51123. I suspect it may be a Haiku rather than a yab error, but I thought I'd report it here anyway.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-11-2017, 12:18 AM
Post: #2
RE: That's funny
(05-10-2017 05:48 AM)clasqm Wrote:  Haven't seen this before: I'm filling a listbox with content

Code:
sub FillListbox()
    local listing$, listing, w$(1)
    listing$ = system$("ls -1 ~")
    listing = token(listing$, w$(), "\n")
    for f = 1 to listing
        listbox add "TheList", f, w$(f)
    next f
end sub

and when run, the program writes this to standard output, whether DEBUG=1 or not

Code:
Range: 241.000000 - 243.000000
Range: 56.000000 - 243.000000
Range: 108.000000 - 243.000000
Range: 108.000000 - 243.000000
...

It's not important, but I prefer my programs to output text only when I tell it to. This happens on Haiku href51123. I suspect it may be a Haiku rather than a yab error, but I thought I'd report it here anyway.
I looked at the yab source and this is not comming from yab. it must be comming from BListView.

Fat Elk Sortware
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Free Web Hosting