yab | yet another Basic for HAIKU

Full Version: Error in hrev 50028
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
THis just showed up for the first time

Code:
~/projects/FuzzyTime/binder> yab
runtime_loader: /boot/system/lib/libyab.so: Could not resolve symbol 'DrawLabel__Q28BPrivate12BControlLookP5BViewPCcG5BRectRC5BRectRC9rgb_colorUlRC10BAlignment'
resolve symbol "DrawLabel__Q28BPrivate12BControlLookP5BViewPCcG5BRectRC5BRectRC9rgb_colorUlRC10BAlignment" returned: -2147478780
runtime_loader: /boot/system/lib/libyab.so: Troubles relocating: Symbol not found

EDIT: Yes, it seems to affect all yab programs. This is using yab-1.7.5.1-1-x86_gcc2.hpkg

Never mind, I see bbjimmy already has a ticket out on this.
And the same by Yab Programs without using libyab.so:

"DrawLabel__Q28BPrivate12BControlLookP5BViewPCcG5BRectRC5BRectRC9rgb_colorUlRC10BAlignment"

i hope it will be fixed.

lorglas

(01-15-2016, 10:28 PM)clasqm Wrote: [ -> ]THis just showed up for the first time

Code:
~/projects/FuzzyTime/binder> yab
runtime_loader: /boot/system/lib/libyab.so: Could not resolve symbol 'DrawLabel__Q28BPrivate12BControlLookP5BViewPCcG5BRectRC5BRectRC9rgb_colorUlRC10BAlignment'
resolve symbol "DrawLabel__Q28BPrivate12BControlLookP5BViewPCcG5BRectRC5BRectRC9rgb_colorUlRC10BAlignment" returned: -2147478780
runtime_loader: /boot/system/lib/libyab.so: Troubles relocating: Symbol not found

EDIT: Yes, it seems to affect all yab programs. This is using yab-1.7.5.1-1-x86_gcc2.hpkg

Never mind, I see bbjimmy already has a ticket out on this.
yes, it seems like they broke yab again ... see https://dev.haiku-os.org/ticket/12592
(01-16-2016, 02:13 AM)bbjimmy Wrote: [ -> ]yes, it seems like they broke yab again ... see https://dev.haiku-os.org/ticket/12592

Huh

It seems that the original yab devs used a private api that has been changed. This will cause many yab programs to need to be re-built to run on haiku post hrev49976. I am fixing the getlatestyab.PM.sh script to make yab build again depending on the hrev.

Be Prepared to re-bind / re-build yab programs. Any program built with earlier versions than 1.7.5 will need to be re-built. programs built with 1.7.5 use libyab, and will not need to be rebuilt. any program bound with yab include their own version of libyab and will need to be re-bound. basicly a yab developer will need to update yab ( once it is fixed ) on a post hrev49976 haiku and test his apps some will be ok, most will not.

I will post here when the script is updated to build yab again.
The GetLatest-yab script is now fixed to build yab on the latest PM builds .... http://yab.orgfree.com/GetLatest-yab.zip

It checks the hrev and replaces the ColorTools.h file in the src/column directory when needed. As usual, follow the updating yab post, http://yab.orgfree.com/forum/showthread.php?tid=8 to end up with a working install.
Those of us still active yabbers can do that. It's an afternoon's work for me.But there are a lot of existing apps like those listed at http://besly.de/index.html?/menu/search/...s_eng.html that are no longer being maintained. For example, I haven't seen StreakX around lately. Perhaps the time has come for us to ummm, adopt those apps if they can be tracked down and keep them updated.

Will you be posting an updated hpkg on your repo?
(01-18-2016, 07:32 PM)clasqm Wrote: [ -> ]Those of us still active yabbers can do that. It's an afternoon's work for me.But there are a lot of existing apps like those listed at http://besly.de/index.html?/menu/search/...s_eng.html that are no longer being maintained. For example, I haven't seen StreakX around lately. Perhaps the time has come for us to ummm, adopt those apps if they can be tracked down and keep them updated.

Will you be posting an updated hpkg on your repo?

I'm still waiting on the ticket, there is a small chance the devs can come up with a work-around for our issue, and they have not made any firm statement one way or another. Fingers crossed.
Does anyone still have a link to the old pre-libyab versions of yab?

Never mind. I found it and it's broken.
(01-19-2016, 04:49 PM)clasqm Wrote: [ -> ]Does anyone still have a link to the old pre-libyab versions of yab?

Never mind. I found it and it's broken.



The same fix should work, comment out YAB/src/column/ColorTools.h line 87 for both yab and Buildfactory. Still won't fix old bound / built binaries. Maybe someone can figure out how to patch a binary to run on the latest Haiku.
yab 1.7.5.2 is available from the FatElk repo. This will require haiku hrev50032, the version it was build on, or higher.

The issue isn't as bad as I first feared. After installing this version, any yab program built or bound with a version of yab that uses libyab.so on a PM version of haiku will run again. Those made with earlier versions of yab or Haiku will have to be re-built.
Pages: 1 2
Free Web Hosting